Traction control off service stabilitrak message

JAVINDRA

Well-Known Member
I am getting a traction control off service stabilitrak message on my onboard diagnostics with audible chimes what could be the cause I understand this is a common issue...thanks Javindra
 

MRRSM

Lifetime VIP Supporter
You might get Lucky... If THIS Switch turns out to be The Culprit and Solve the "Service Stabilitrak" issue... which can present you with some VERY SERIOUS SAFETY Issues if your Engine suddenly and unexpectedly Loses Power. Examples of the implication are:

(1) Attempting to Enter Fast Interstate Highway Traffic via On Ramps.
(2) Climbing STEEP Grades in Bad Weather.

You get the Idea...

 
Last edited:

Mooseman

Moderator
You need to get the code read by a high end scanner or Tech 2. If that is the only light on (no ABS light), then it's likely the SWPS (steering wheel position sensor) . This is especially true if it happens when you first turn the wheel.
 
OP
OP
J

JAVINDRA

Well-Known Member
You need to get the code read by a high end scanner or Tech 2. If that is the only light on (no ABS light), then it's likely the SWPS (steering wheel position sensor) . This is especially true if it happens when you first turn the wheel.
Hi mooseman it's nice to hear from you again I used to talk to you when I had my envoy i now have a 08 acadia anyway my issue is with the onboard diagnostic message traction control off and also service stabilitrak . I don't have any engine lights on my dash just the diagnostic message. I understand it is a common issue with alot of causes such as a faulty wheel bearing hub or sensor a brake position sensor or steering wheel position sensor to name a few any help would be appreciated thanks Javindra
 

Mooseman

Moderator
If it was a wheel hub, you would also get an ABS error. That's why I'm leaning towards the SWPS. A code reader would confirm this.
 
Last edited:
OP
OP
J

JAVINDRA

Well-Known Member
If it was a wheel hub, you would also get an ABS error. That's why I'm leaving towards the SWPS. A code reader would confirm this.
I have a standard obd2 reader but no codes for this do you know if it was the SWPS sensor would it be picked up with a standard reader or do you need a special reader and what would the code be thanks Javindra
 

Mooseman

Moderator
You need a special high end scanner.
 

Online statistics

Members online
6
Guests online
379
Total visitors
385

Forum statistics

Threads
20,344
Messages
593,591
Unanswered questions
2
Answered questions
2
Members
13,377
Latest member
Wheelybar
Top Bottom