TB kicked me out doesn't wanna start

shadiBLebz

Original poster
Member
Apr 19, 2012
52
OHHH KAY.

Here's the deal fellas. Just took a road trip from out west to Toronto for vacation. Dorve no problems smooth as heck loved it. Any how second day in TO and truck decided to say eff you I've had enough and refused to start. I waited it out and sat waiting for a tow to the nearest mech shop. Got droped off. Took 3 days for these clowns to call n tell me its my BCM then the next day calls me and tells me I need a new fuse box that they had to by pass fueses and relays to start it lie wtf is going on? I'm not sure if this guy is just trying to rape me for some cash or what any ideas?
 

Denali n DOO

Member
May 22, 2012
5,596
3 days just for the call? I would have lost it by then! That just sounds like a bunch of bs, by pass fuses and relays to get it started, is that comment to make you think they are smart? I can't say much about the no start you have, mine was hit and miss. First they tried an ignition switch and then a new starter was put in. I'm curious to see what others have to say about your no start. I wonder if the Mega Fuse would cause this? I hope you aren't gettin screwed over!
 

shadiBLebz

Original poster
Member
Apr 19, 2012
52
Needless to say i am still fuming the guy told me 3 hours and ill have figured it out so i agreed to the 3 hours. next day i call and hes like maybe its your remote starter and i told him i dont have a remote start. hes like yes you do i need to disconnect it to see if that is causing it to not start so i am like ok not like i even knew i had that thing since i bought it used. and then yesterday i talk to the guy hes like i wanted to see if i can fix you bcm and it turns out you need a new fuse box and he has to call the dealer so i am like ok so what 500 bucks and its over with and hes all like.... no no no i put alot of time and labour into this and i have to add everything up come see me on monday and you will see what i am talking about, but if this guy thinks hes gonna get a penny out of me for some shoe maker job. i dont think so he has abnother things coming.


what i want to know is do i have to pay for bs service that are half done and the guy acting like he know what hes talking about?
 

MAY03LT

Member
Nov 18, 2011
3,412
shadiBLebz said:
....tell me its my BCM then the next day calls me and tells me I need a new fuse box that they had to by pass fueses and relays to start it..

If you can find out what they did to start it we could probably tell you what is wrong.
 

shadiBLebz

Original poster
Member
Apr 19, 2012
52
MAY03LT said:
If you can find out what they did to start it we could probably tell you what is wrong.

What the guy told me was there are some fuses that are not getting power so he bypassed them to get everything working and I need a new fuse box I asked w/e you did to it can I drive it back home to calgay he says I think so but u can't put your back seat down because of what I had to do
 

Denali n DOO

Member
May 22, 2012
5,596
Fire06 said:
Let us know what he did in the end sounds interesting :undecided::undecided:

Ya I want to hear the outcome too! Maybe he can fix my HVAC with a few bypasses...:undecided:...
 

The_Roadie

Lifetime VIP Donor
Member
Nov 19, 2011
9,957
Portland, OR
Many of the fuses in the rear fuse box can be left without power due to a bad ignition switch or one of two bad J-case fuses in the front fuse block. Sounds like this guy doesn't have the schematic.

A Megafuse failure will kill interior lights, HVAC and entertainment functions, but it will not affect how the truck starts or runs. Guaranteed.
 

shadiBLebz

Original poster
Member
Apr 19, 2012
52
the roadie said:
Many of the fuses in the rear fuse box can be left without power due to a bad ignition switch or one of two bad J-case fuses in the front fuse block. Sounds like this guy doesn't have the schematic.

A Megafuse failure will kill interior lights, HVAC and entertainment functions, but it will not affect how the truck starts or runs. Guaranteed.

Well what happend the night before this was I locked the truck woth the keyless entry and when I came back the remote did not work no unlock/lock panic. I opened the door with they key and the security light on the ddash was flashing I tried to start iot but nothing had no interior lights no start no lock or window power or radio. I checked all fuses everything seemed ok. So I kicked and yelled for a bit and threw my remote and then the panic alarm went off. And everything started working again the next day same thing happed as I was downtown with my family except door were already unlocked and no security light. So I'm not sure what the hell happened and I do not understand since one min its the BCM then its my fuse box like not sure what to make of it
 

Mooseman

Moderator
Dec 4, 2011
24,180
Ottawa, ON
Sounds like something with the BCM and possibly kicking in the VATS (vehicle anti-theft system) or the ignition switch that's gone bad. A lot of electrical issues can be caused by a bad ignition switch. Is this a dealer you took it to? If so, they're idiots as this problem would be easy to diagnose with a Tech2 scanner.
 

shadiBLebz

Original poster
Member
Apr 19, 2012
52
Mooseman said:
Is this a dealer you took it to? If so, they're idiots as this problem would be easy to diagnose with a Tech2 scanner.

No not the dealer, it was a 24hr shop that I thought would possibly pull there heads out of a donkeys ass n think a little but no.
 

The_Roadie

Lifetime VIP Donor
Member
Nov 19, 2011
9,957
Portland, OR
A 24 hour auto repair place? :confused: That takes three days to diagnose a bad fuse block incorrectly? We don't have the advantage of being in front of the truck so none of us are going to be any more competent at guessing than they are. And it's not like you can take our ideas and rub it in their faces and get them to suddenly wake up and smell the coffee.

Let us know when you get it back working, and perhaps we can tell you how to fix it right. I assume you don't have a voltmeter or any tools with you. :confused:
 

Chickenhawk

Member
Dec 6, 2011
753
It sounds to me like a $30 ignition switch was the cause, and they blew the megafuse trying to jump it incorrectly.

Call me cynical. (But call a lawyer.)
 

McGMT

Member
Jun 17, 2012
621
the roadie said:
A 24 hour auto repair place? :confused: That takes three days to diagnose a bad fuse block incorrectly? We don't have the advantage of being in front of the truck so none of us are going to be any more competent at guessing than they are. And it's not like you can take our ideas and rub it in their faces and get them to suddenly wake up and smell the coffee.

Let us know when you get it back working, and perhaps we can tell you how to fix it right. I assume you don't have a voltmeter or any tools with you. :confused:

Roadie, I don't think they had the car in front of them either.... Another example of people who know how to work on a carb. but not a newer vehicle. They don't understand the data systems of this vehicle, and still think this part gets power and does this and the part beside it has nothing to do with this part or that part and they go thinking they know whats wrong or whatever and POW your screwed outta some loot and they sit there thinking they are a genius. And whatever you do don't try to explain the data bus circuitry to them, they might burn you at the stake for being a witch/warlock.

Personally, I really want to meet these idiots.:dunce:
 

MAY03LT

Member
Nov 18, 2011
3,412
McGMT said:
....and still think this part gets power and does this...

You mean like the non-existent wire that goes from the ignition switch to the starter solenoid?
 

The_Roadie

Lifetime VIP Donor
Member
Nov 19, 2011
9,957
Portland, OR
I think their brains would explode if they had found a chart like this:

RED on the ignition switch is 12V, fused by underhood fuse #34, and feeds the following three circuits:

White is hot in ACCY, RUN, START
Orange is hot in RUN
Yellow is hot in START

RED/WHITE is another 12V, fused by underhood fuse #36, and feeds two circuits:

Brown is hot in ACCY, RUN
Pink is hot in RUN, START

And that many of the fuses in the REAR fuse block (the ones they probably bypassed) are not fed by the megafuse, but by some of these switched ignition circuits. I've seen it posted in error at the OS that the megafuse feeds EVERYTHING in the rear fuse panel. :no:

I guess a subscription to Mitchell or AlldataDIY is not part of the minimum fish & game standards to be a professional mechanic nowadays?
 

McGMT

Member
Jun 17, 2012
621
Yep... Unfortunately now a new fuse box is needed because that hick destroyed it... I can hear him now, "what is this other box with all these connectors, what is this green plastic thing with lines going thru it. " Oh my..
 

shadiBLebz

Original poster
Member
Apr 19, 2012
52
Ok so I got my poor baby back yesterday after spending 4hrs waiting for him to finish his stupidity. Me and my father inlaw show up and this guy has wire coming out from the fuse box were the BCM aaptor goes on the A and B side and he has all theses sheets with the circut diagrams out in front of him.

He started explain there were lines not reciving power a9 b13 and a19. That he stuck some wires in and attempted to give thenm power. As I stood looking at this he walked away. I took photoS and pulled all that crap out n started the TB my self started no issue. He returned and I told him it starts fine but no he said it won't last because the comp will read no power and do the same thing again and if I wanted him to put in a new fuse box I wouldn't get it till. (Tommo) today. I told him no that's fine I will change it out my self later. He plugged in his dignostic comp. No codes showed up but was persistant to tell me the codes will show up u have to wait. @ this point I'm annoyed

I asked him to show me were there was no power he plugged in his tester and proceeded to show me but to no avail each point he told me had no power lit up :o wow so wtf r u trying to tell me sir that u have no flippin clue as to what your doing? Stood there for a few min with a dumbfounded look on his face and said it is possibley an intermottint problem. I told him just take your shit out please I've had enough. He attempted to charge me for 10hrs labour @ 80hr and then 60 to repar the condenser or w/e in the bcn. Luckly my father inlaw was there did some talking to the owner of the shop n dropped it to 500 even. Still paid had no choice but man what a nght mare. I'm going to try n post the pics I took. If my phone allows me too.
 

shadiBLebz

Original poster
Member
Apr 19, 2012
52
ok I attempted to post the pics first time so bear with me
 

Attachments

  • IMG-20120625-00270.jpg
    IMG-20120625-00270.jpg
    92.7 KB · Views: 14
  • IMG-20120625-00271.jpg
    IMG-20120625-00271.jpg
    93 KB · Views: 7
  • IMG-20120625-00272.jpg
    IMG-20120625-00272.jpg
    94.7 KB · Views: 8

The_Roadie

Lifetime VIP Donor
Member
Nov 19, 2011
9,957
Portland, OR
It doesn't seem reasonable that such a clean fuse block would have more than ONE intermittent fuse to need bypassing. Much more likely to be the flaky ignition switch, harness, or front fuse block J-case fuses that feed the ignition switch. But we're here, you're there, and there's only so much an internet forum can do without owning its own remote robotic repair avatars. :wink:
 

Uncle Blazer

Member
Dec 8, 2011
263
At least he didnt try to tell you it was because somebody unhooked a red wire by the battery. Well there's your problem right there.
 

Denali n DOO

Member
May 22, 2012
5,596
shadiBLebz said:
ok I attempted to post the pics first time so bear with me

Wow, $500.00 for that? I don't think I'd be too happy :hissyfit: . Are any of those wires actually attached :confused: . I think he scammed you. You might even had gotten a better cheaper fix at the Stealership :undecided: . I hope we hear what the actual problem is.
 

SAR85

Member
Jan 31, 2012
74
It doesn't look like either of those wires are connected to anything and just have a clamped-on terminal hanging loose.
 

McGMT

Member
Jun 17, 2012
621
I cant believe that idiot tried tapping into the connector for the ribbon cable from the BCM... Im not imagining that am I? You see it too right? He definitely has no clue what so ever to how the systems on this vehicle operate... It's funny, this isn't my vehicle and I don't even know you but I am totally pissed off about this and wanna go after the idiot part changer that touched it! lol

Goosfrabaaaaaa
Goosfrabaaaaaaaa

Alright, I am calmed now... :lipsrsealed::hissyfit:
 

shadiBLebz

Original poster
Member
Apr 19, 2012
52
Stealership costs. 280 new BCM.
380 new Fuse Box
Hourly rate 110 cad.

Mech cost. 80 to repair some condensers in the BCM
10hrs/ 80 hour. Because he was a flippin chooch that had no clue as to how his life was working out


Just so yall know I ripped out those wires, he looked @ me and told him he was gonna fry my system and said no no no it has to be like this if u do not let me order you a new fuse box. Blah blah blah. No I don't need anything else. How about you close everything up please. You have done enough
 

MAY03LT

Member
Nov 18, 2011
3,412
Wish there was a pic with all of the jumpers in place. Would have been cool to figure out what was wrong based on that.
 

Fire06

Member
Dec 18, 2011
7,223
Glad to hear you made it out of there with the truck at least running:wootwoot::wootwoot:
 

shadiBLebz

Original poster
Member
Apr 19, 2012
52
I appriciate all the support fellas. Had my tb for about a week now no issues except when I depress my breaks the interior lights don't do that on and off thing before I drive anymore. Oh well


I'm thinking the green ribbons may have come loose when I was trying to start it previously the the night prior. Ahh when I get home I'm going to take a better look @ it ill have my tools and my buddy with me to try and diagnose what it could have been.

Once again I am greatful for the support. :thumbsup::thumbsup:
 

Forum Statistics

Threads
22,739
Posts
630,680
Members
17,532
Latest member
roxandez

Members Online