SUPPORT {SOLVED!} Problems with Firefox Failed Addons-Non-Signed APIs

Status
Not open for further replies.

MRRSM

Lifetime VIP Supporter
Not being a "Luddite" by any stretch of the imagination, it makes me look like one whenever I go into a Rage about the Technical 'Droogs' over at Firefox tinkering with features that always seem to work fine... until they start Fiddle-F*****g around with them... and then they DON'T!

If you haven't noticed this problem yet... check your "Add-Ons" feature in the Menu Index of your Firefox Browser and do not be surprised if the majority of them have been either disabled or deleted....providing an Error Message when downloading them that reads:

"Download failed. Please check your connection."

...Which is just a Crock of Steaming Horse Manure... because the actual problem has to do with them 'changing the rules' that will ONLY allow SIGNED and VERIFIED Add-On APIs to the Browser. I wish these Firefox Mopes would simply leave well enough alone and stop lying to their Browser Users about a problem that has nothing whatsoever to do with the End User Hardware when browsing with the Firefox Application.

If you have discovered an easy fix or a work-around for these Add-On Issues, Let us All Know.... Please.


FIREFOXADDONPROBLEM.jpg

For any Linux OS Users... I already tried to install the Debian Alternative Browser for Firefox on my Dell Precision M4700 Laptop as a work-around called "Ice Weasel" and this what the 'sudo install... reply advised on the Terminal Screen:

ICEWEASEL.jpg

So unfortunately... THAT was no solution...
 
Last edited:

Mooseman

Moderator
Crap, just noticed that Ad Blocker has been disabled. A number of my add-ons have been disabled :mad:

A quick Google search reveals that this was unintentional and a fix should be install itself if you have the setting as described enabled.

 
OP
OP
MRRSM

MRRSM

Lifetime VIP Supporter
For anyone experiencing problems with the Firefox Browser disallowing Unsigned Add-Ons and Security Features or disabling existing ones... Until they sort out these problems... You might try out using the alternative Browser Called "Opera" which will allow you to "Add" in Ad-On Ad-Blockers, Video Downloaders, etc.

For the Admins and Mods... Please be advised that when using the latest version of Firefox on Linux Mint 19.1 Operating System... ALL of the Advertisements in the Right Column are BLANKED OUT (Whited Out, Actually). However... after loading and setting up the "Opera" Browser... I can see ALL of the Advertisements in a normal fashion. For anyone interested in this temporary Internet Browsing Option... here is the link to "Opera":

 
OP
OP
MRRSM

MRRSM

Lifetime VIP Supporter
On Thursday, May 9th, 2019 at around 02:00 AM... I received a Linux Mint Ver. 19.1 Software Update Alert that came as a .DEB File automated download in the name of "Firefox". Ordinarily, once any Updates are initiated via the LM "APT" GUI Program called "SynAPTic"... after they properly install and get completed, any earlier Failed or Problematic .DEB Files get removed from the computer to keep the Operating System as clean as possible. Such was the case here... and as soon as I opened the Firefox Browser... All of the recently Failed Add-Ons were working properly again.

Please check your Windows and MAC Machines Firefox Browser Add-Ons to verify that yours are also working again as well. I'm not sure that I'll continue using the Firefox Browser henceforth because the Opera Browser has proven itself to work much faster and easier AND the Text and Images appear much more clear and less 'fuzzy' around the edges. I've been enjoying using it as a stand-in for the Firefox Browser....AND One More AND...

And it comes with a
FREE VPN (Virtual Private Network) Capability!

Time will tell...

I think we can Mark This One as being [SOLVED!]
 
Last edited:
OP
OP
MRRSM

MRRSM

Lifetime VIP Supporter
EDIT: A BETTER "FIX" AS A WORK-AROUND (Saturday, October 26, 2019 @12:37PM)

I tried using the following Apt Commands for the Installation of the Latest Firefox Ver. 70.0+ Browser...AND IT WORKED WITH ALL ADD-ONS AND EXTENSIONS... using THIS Command Line:

sudo apt install iceweasel

This Information is meant for Linux Users of Firefox... but MAY also be Affecting Windows Users as well:

I’ve had trouble with the latest Firefox Ver. 70.0+. After it Auto-Updated, I was unable to use ANY Extensions or Add-Ons such as ADBlocker or VideoDownloadHelper. I wound up having to re-install Linux Mint 19.2 on a larger (2 TB) Hard Drive and did so from from a legacy DVD ISO.

During the requisite Updates using the Synaptic Package Manager for .DEB Packages… I observed that the Firefox Update for the Latest Ver. 70.0+ was just WAITING on the List to be installed… so I Deselected it in the Check Box:

LINUXUPDATE.jpg

However… after every New Check for any further Linux Mint Package Updates… The Synaptic “Shield” would Pop Up and indicate that same Firefox Update 70.0+ option for selecting it again was still there. The Work-Around for stopping problem requires these (2) Distinct Actions:

(1) The First Fix entails opening Firefox and using the empty URL (config) Line to enter these Commands:
  1. Type about:config into the address bar
  2. In the filter field, enter: app.update.enabled
  3. Right Click on the line
  4. Select “Toggle” to Set it to false
  5. Then again... Type into the Filter field: app.update.auto
  6. Right Click on the line
  7. Select “Toggle” to Set it to false
This should Stop allowing Firefox to Auto-Update itself whenever you are Browsing.

(2 Next… in order to deal with the Firefox 70.0+ Linux Update appearing in the Synaptic Update Manager “Blue Shield”, these steps needed to be followed using the Linux Mint Terminal and Command Lines:

After typing in THIS...

sudo apt update

...If you get any messages in the Terminal advising there are Packages that CAN be Upgraded rather than being just Updated… use this Apt Command to list the ones available… BUT... DO NOT NOT TYPE IN THIS UPGRADE COMMAND:

sudo apt upgrade

Instead… Identify which remaining Packages you want to Upgrade RATHER THAN AUTOMATICALLY INCLUDING FIREFOX Ver. 70.0+ in those choices and use THIS Alternative Apt Command:

sudo apt install - -only-upgrade (and include JUST the name of the individual .DEB packages you want to Upgrade) (TYPE This in the Terminal… DO NOT COPY PASTE IT FROM HERE!)

I’ve Tested these Linux Apt Commands and Firefox ‘config’ Line Edits this morning, and they all work. My New Linux Mint installation runs swimmingly now. Firefox and The Add-Ons and Extensions ALL Work… and now, I’m not being plagued by Firefox 'Auto-Updating' itself.

For Linux User Only... If you want to know Which APT Application Upgrades are Available... but Do NOT want to Install ANY Upgrades by Default... this 'Lil' Bit of PERL Code' will present them On Screen, showing the Ones presently installed right alongside with the Latest Upgrade Versions:

Just "Copy & Paste" this entire line into a Terminal and Press the <E> Key:

apt-get --just-print upgrade 2>&1 | perl -ne 'if (/Inst\s([\w,\-,\d,\.,~,:,\+]+)\s\[([\w,\-,\d,\.,~,:,\+]+)\]\s\(([\w,\-,\d,\.,~,:,\+]+)\)? /i) {print "PROGRAM: $1 INSTALLED: $2 AVAILABLE: $3\n"}'
 

Attachments

Last edited:
OP
OP
MRRSM

MRRSM

Lifetime VIP Supporter
Status
Not open for further replies.

Online statistics

Members online
3
Guests online
101
Total visitors
104

Members online

Forum statistics

Threads
19,730
Messages
584,467
Unanswered questions
1
Answered questions
1
Members
12,479
Latest member
TrentRichens
Top Bottom