Secondary Air Pump (NOT a P0410 issue...different!!)

pejeeper

Original poster
Member
Jan 27, 2012
81
I stopped to fuel up and left the ACC on for kiddo to listen to the radio. I heard a high pitch whining coming from driver's side underneath, not the sound I hear at start-up, softer. I dismissed it as a fan running with the ignition in ACC.

1 mile drive home, park in the garage, take kid out go get mail, go inside...nothing strange heard.

Wife comes home 30 mins later and says there's a strange noise coming from the TB. I go out and the SAI pump is running full tilt...stopped when I opened the driver's door.

WTF?
 

The_Roadie

Lifetime VIP Donor
Member
Nov 19, 2011
9,957
Portland, OR
Could only be a stuck relay down by the pump. There is no possible electrical connection to opening the door, so it must have just jostled it to open up. The relay gets constant 12V power, and doesn't go through the ignition switch to positively turn it off. Just pull front fuse 56 to disable the pump for now until you can dive down underneath and examine the relay. Worst that will happen is you'll get a benign SES light with the P0410 code.
 

pejeeper

Original poster
Member
Jan 27, 2012
81
Thanks for the help. I do have a spare relay on the shelf I can pop in....when I splice in the new headlight socket.
 

pejeeper

Original poster
Member
Jan 27, 2012
81
Must've popped back on...battery dead and truck won't start.

Pulled front fuse #56, whining stopped.

Charging battery jumper b/c apparently that died too.

Gotta find that spare relay.

No I'll probably have to clean the throttle body too this weekend, it has 35k on the last cleaning....since the computer probably reset from the dead battery.
 

pejeeper

Original poster
Member
Jan 27, 2012
81
No luck on the old relay, must've trashed it...but I did find the old check valve...if I had kept it, I would have put it with the check valve. But while waiting for the jumper pack to charge, I swapped out the headlight socket (see my other thread).
 

pejeeper

Original poster
Member
Jan 27, 2012
81
Jumper pack is toast. Bought a battery charger/tickle charger/started combo unit from Harbor Freight (with a 20% off coupon!) and the truck fired right up.

Battery is OE, so I need to add that to the list of maintenance/replacement. Going to order 2 SAI relays tomorrow.
 

Wyle

Member
Dec 4, 2011
200
the roadie said:
Sometimes (very seldom) I wish Mrs. Roadie had a fuse #56. :wink:

:rotfl::rotfl:

I hope she doesn't read your forum contributions. :eek:

I used to point the remote at the kids and hit the mute button. Only worked once.
 

Forum Statistics

Threads
23,488
Posts
639,901
Members
18,722
Latest member
Mmc0229

Members Online