Rear view mirror temps going goofy...

Boricua SS

Original poster
Member
Nov 20, 2011
3,080
Ohio
ok, so my temperature on my mirror has been going goofy lately... like today, it was 80* here and my mirror was reading 105*.. the other day it was 50* and it was reading 75*, and so on... so through some searching.. it looks like the AAT sensor is going faulty in my SS... its located behind the grille kinda towards the battery in front of the radiator... costs less then $10 bucks...

here's my question... I know for you LT and 3SS digital hvac folks, you have a sequence of buttons to hit to reset things (cant remember what those were)... but what about the manual HVAC folks? what if the sensor is not the issue? what else could it be for me? I could care less if the temps were being displayed semi accurately, but I also read on ssowners that it could mess with the AC if things aren't read or calculated properly.. any truth to that?
 

Sparky

Member
Dec 4, 2011
12,927
Try cleaning the sensor first. I know it is a different car, but my brother's Ford will start doing that when the sensor gets cruddy.

If you have manual HVAC then the sensor does nothing but tell you what the temperature outside is.
 

Boricua SS

Original poster
Member
Nov 20, 2011
3,080
Ohio
Sparky said:
Try cleaning the sensor first. I know it is a different car, but my brother's Ford will start doing that when the sensor gets cruddy.

If you have manual HVAC then the sensor does nothing but tell you what the temperature outside is.

Thx Jarod... gonna try that when I get off of work this afternoon. Good to know about the manual hvac's as well..
 

Denali n DOO

Member
May 22, 2012
5,596
Boricua SS said:
ok, so my temperature on my mirror has been going goofy lately... like today, it was 80* here and my mirror was reading 105*.. the other day it was 50* and it was reading 75*, and so on... so through some searching.. it looks like the AAT sensor is going faulty in my SS... its located behind the grille kinda towards the battery in front of the radiator... costs less then $10 bucks...

here's my question... I know for you LT and 3SS digital hvac folks, you have a sequence of buttons to hit to reset things (cant remember what those were)... but what about the manual HVAC folks? what if the sensor is not the issue? what else could it be for me? I could care less if the temps were being displayed semi accurately, but I also read on ssowners that it could mess with the AC if things aren't read or calculated properly.. any truth to that?

I think the reset is pressing front defrost, rear defrost and airflow mode at the same time.
 

Boricua SS

Original poster
Member
Nov 20, 2011
3,080
Ohio
Denali n DOO said:
I think the reset is pressing front defrost, rear defrost and airflow mode at the same time.

Yea I can't do that :rotfl:...

I have manual hvac controls, so I don't have buttons, I have turn dials...I have the rear defrost and airflow button, but I have the dial for front defrost, not a button..
 
Feb 29, 2016
195
Radford, VA
Hey, Boricua SS, what was the final outcome on this? I'm having a similar issue.
 

Forum Statistics

Threads
23,483
Posts
639,847
Members
18,716
Latest member
sloftin

Members Online