Passenger side wiper arm not moving

ptrkptz

Member
As a previous Envoy owner, I have followed this forum (after moving from a previous :wink:) and found alot of good information, and was looking for some new help.
I was not sure were to put this, as there is not a Theta forum, but I recently purchased a Terrain for the DW.
Yesterday, she came home and said the passenger wiper arm quit moving, while the driver side is working fine.
I imagine there is a sheer pin or some mechanism to prevent breaking something (in case the arm is froze down).

I have searched the Internet for some info to no avail. DW is to be back by noon, and I was gonna dig into the issue, but thought that someone may have some information or a resource to take a look at.
 
OP
OP
P

ptrkptz

Member
Something so simple... popped the covers off the wiper arm studs, and turn the wipers on, the stud was moving, found the nut was loose. Torqued the nut back down and all is good.
 

jsheahawk

Well-Known Member
ptrkptz said:
Something so simple... popped the covers off the wiper arm studs, and turn the wipers on, the stud was moving, found the nut was loose. Torqued the nut back down and all is good.
That's the best kind of problem! You might consider putting some blue thread locker on it.

Jared
 

Too Fast

Well-Known Member
ptrkptz said:
Something so simple... popped the covers off the wiper arm studs, and turn the wipers on, the stud was moving, found the nut was loose. Torqued the nut back down and all is good.
Glad you had a simple fix. It will last, and may last a long time.

A better way to fix this problem is to remove the wiper arm off the stud, clean the splines on the stud with a small wire brush or a small pick, then put the wiper arm back on. That way, the aluminum wiper arm that was loose on the stud will be less likely to strip on the stud again since it will now be pressed on the stud better since the stud splines are clean of aluminum.

Be sure to have the wiper arm oriented correctly before tightening that nut!
 

Online statistics

Members online
4
Guests online
249
Total visitors
253

Members online

Forum statistics

Threads
20,346
Messages
593,678
Unanswered questions
2
Answered questions
2
Members
13,382
Latest member
jmkinmsp
Top Bottom