Oil leak at front crankshaft seal

#1
I have a 2002 trailblazer 4.2L with an oil leak at front crankshaft seal. It seems to be fine at idle, but starts gushing at 2000 - 2500 rpm. I pulled the balance and replaced the seal, but it is still leaking (might even be a little worse).

Any idea what could be causing this?

I did re-use the old balancer, and there did seem to be a slight groove cut in it (maybe from the old seal), so I guess it could be a bad balancer.

Is it possible that it could be too much pressure in the crankcase?
 
#2
Welcome to the Nation! Glad you made it despite our email issues.

I haven't heard of many issues with the front seal leaking on these except for slight sweating past the seal. How many miles on it? How deep was the groove? Have you seen the oil actually coming out from there while running? It is possible that it's coming from the timing chain cover or oil pan seal and dripping onto the balancer.
 
OP
OP
B

bgonzo

New Member
#4
Yes, I can actually see it coming from the seal when the engine is running. Its a slow drip at idle and heavier at part throttle. I cant tell for sure if its coming from the O.D. or the I.D. but it is definitely the shaft seal and not the timing cover.

The truck has 190,000 miles.
The groove was deep enough to see clearly and feel with your fingernail. I'd say .005 to .010 inch deep. I remember seeing it, but didn't know if it was a wear mark or a machined feature.
 
#5

Tiggerr

Well-Known Member
#7
bgonzo said:
Yes, I can actually see it coming from the seal when the engine is running. Its a slow drip at idle and heavier at part throttle. I cant tell for sure if its coming from the O.D. or the I.D. but it is definitely the shaft seal and not the timing cover.

The truck has 190,000 miles.
The groove was deep enough to see clearly and feel with your fingernail. I'd say .005 to .010 inch deep. I remember seeing it, but didn't know if it was a wear mark or a machined feature.
Usually that a wear mark. You'll probably need a new balancer and seal.
 
#8
I have a 2002 trailblazer 4.2L with an oil leak at front crankshaft seal. It seems to be fine at idle, but starts gushing at 2000 - 2500 rpm. I pulled the balance and replaced the seal, but it is still leaking (might even be a little worse).

Any idea what could be causing this?

I did re-use the old balancer, and there did seem to be a slight groove cut in it (maybe from the old seal), so I guess it could be a bad balancer.

Is it possible that it could be too much pressure in the crankcase?

Hi
You did it solve the problem with the seal and leakage of oil from the crankshaft?
When you get the Harmonic Balancer, as you managed to lock the crankshaft to loosen the Harmonic Balancer bolt ?
 

Forum statistics

Threads
18,655
Messages
567,583
Members
11,281
Latest member
ibeni
Top Bottom