Non-starting GMC Envoy XUV / I6

chicoI6xuv

Original poster
Member
Jul 16, 2013
1
Hello, I have a 2004 GMC Envoy XUV i6. Have had to luck in getting my XUV to start!!
I have tried several suggestions ; replaced bad starter,put in a new battery,replaced both the ignition switch and parking lock unit-which are near each other.
The lock unit keeps getting "red hot" to the touch, why???
Is there a possible headlight unit that now keeps the dash lights on, draining my battery????
Had replaced 2-batteries, covered under warrant-tee.
It's been at least 3-months with this issue of not able to start,have the clicking to the starter- but NO cranking. Checked that the motor did not seize, hand-turned OK.
I am in great need of HELP. My last-chance for doing my Emissions is due AUG. 4. Then I will have suspended tags- not running at all.

Thanks for any help.
 

The_Roadie

Lifetime VIP Donor
Member
Nov 19, 2011
9,957
Portland, OR
Nothing under there should be getting that hot. Can you check the battery voltage after you have the key off and watch the voltage go down? Might be the ignition switch was installed incorrectly and not going fully off when you think it's off.

Have you downloaded the schematics and done some basic electrical troubleshooting in the ignition switch area?
 

RayVoy

Member
Nov 20, 2011
939
I'm reading between the lines here; but, to me, it sounds like you can't start because the battery is always dead when you try to start it.

It also sounds like you have an electrical drain somewhere that is killing the battery.

Have you tried to start the truck by getting a battery jump boost?
 

Forum Statistics

Threads
23,483
Posts
639,847
Members
18,715
Latest member
ozzyextlt

Members Online