Need help figuring out why the Trailblazer won't start after replacing radio.

Mooseman

Moderator
What did you replace it with? Another factory radio or aftermarket? Use an adapter or interface?
 

Mooseman

Moderator
Check all your fuses, under hood and back seat. Not just visually but with a DMM or test light. Check ignition switch output.

Does it crank and not start or it doesn't crank at all? This question will determine the path you'll be following.
 
OP
S

Scobee

Member
It won't crank and I now have to push a little button in to gave the key out. With it running I pulled the aftermarket radio out and put the factory radio back in. So all the lights come on when I turn the key but when I go to start it nothing happens.
 

Blckshdw

Moderator
I now have to push a little button in to gave the key out.

This is usually a sign of a low battery. Can you verify the voltage you've got? What happens when you connect a charger, jumper box, or try to jump start it?
 

gmcman

Well-Known Member
How was the aftermarket radio wired?

Did it have a plug-n-play harness, or did this involve cutting wires?

Did any wire accidentally ground out? Any sparks?

I would start with the 125A maxi fuse in the front of the fuse box and do what Mooseman suggested, start checking fuses, both the underhood fuse box and under the LR seat.

Hopefully you didn't get a short and damage the BCM.
 

Online statistics

Members online
7
Guests online
261
Total visitors
268

Members online

Forum statistics

Threads
21,362
Messages
610,609
Members
15,191
Latest member
cgorman18d

Secure Browsing

Top Bottom