My new to me 2006 9-7x 5.3 rebuild

Jul 6, 2014
9,209
You have two copies of momentary lapse of reason like I do.... right? It's not gone forever.... right? It certainly wasnt great...:rotfl:
 

TollKeeper

Original poster
Platinum Donor
Dec 3, 2011
6,711
Brighton, CO
Unfortunately, it was my only copy!

Went to the DMV to get plates... Guess who isnt open on Mondays?!
 
Jul 6, 2014
9,209
Unfortunately, it was my only copy!

Went to the DMV to get plates... Guess who isnt open on Mondays?!
Did you present your new to you SSC?
 

TollKeeper

Original poster
Platinum Donor
Dec 3, 2011
6,711
Brighton, CO

TollKeeper

Original poster
Platinum Donor
Dec 3, 2011
6,711
Brighton, CO
Crap. I can't see it too well but what does the cam lobe look like. My question would be why did it bend? Usually happens when there is piston to valve contact, which would be from another catastrophic failure. The only thing I can think of that may have caused this was that it was run like this for a long time and bent the rod over time.
So got a answer to this.. When the lifter exploded, and the spring was no longer part of that lifter, it stayed in the compressed position. This allowed the pushrod to drop out of the rocker cup. When this happened, the rod probably ended up resting on the Rocker Trunion, Or the Rocker pivot. When the cam came back around, it pushed up on the collapsed lifter, and.... bent rod. I am thankful it didnt push the rocker out of the head. Drilling out, nut-cert, and possible re-Thread was not on my list of things I wanted to do.
 
Last edited:
Jul 6, 2014
9,209

Mooseman

Master Blaster
Moderator
Dec 4, 2011
22,325
Ottawa, ON
The important thing was that the damage was limited and repairable.
 

TollKeeper

Original poster
Platinum Donor
Dec 3, 2011
6,711
Brighton, CO
Jul 6, 2014
9,209
This is true lol.
 

TollKeeper

Original poster
Platinum Donor
Dec 3, 2011
6,711
Brighton, CO
Plates and Tags = Done!

For the time being, this rebuild is mostly done. I still have to do that Brake Pressure Sensor Bung/Gasket/whatever, but its currently not leaking, so...

I did notice a new issue, of sorts..

The tires are supposed to be 255/55R18
The tires on it are 235/60R18 and are nearly new.

I have to run some of the tire out, but luckily the difference in tire size is only about 0.2% on the speedometer. They ride pretty well, but you can definitely see that the tires dont fill the wheel well like they should.

 
Last edited:

TollKeeper

Original poster
Platinum Donor
Dec 3, 2011
6,711
Brighton, CO
Had to return the spark plug wires, they where shorting out and causing a miss fire in cylinder 6
 
  • Wow
Reactions: Matt and Mooseman

TollKeeper

Original poster
Platinum Donor
Dec 3, 2011
6,711
Brighton, CO
Is the transfer case on this 9-7x going to be Autotrak or Dex?
 

Mooseman

Master Blaster
Moderator
Dec 4, 2011
22,325
Ottawa, ON
Auto Trak II, the same smurf blood as the 4x4.
 

flyboy2610

Registered Member
Aug 24, 2021
196
Lincoln, Ne.
Auto Trak II, the same smurf blood as the 4x4.
I had a co-worker whose husband filled a small bottle with blue windshield washer fluid and told his little boy he had run over a Smurf. The kid freaked out! Mama was NOT happy! :hissyfit:
 
  • Haha
Reactions: Matt

TollKeeper

Original poster
Platinum Donor
Dec 3, 2011
6,711
Brighton, CO
New ACD wires- Done! Misfire is gone
Oil change- Done!
Transfer Case- Done! Bright blue fluid out. New blue fluid in
Front diff- Done! Extremely low. I don't know how much came out, but not much. It smelt kinda burnt.

Rear diff not done. I would have to drop the spare tire, and I was worn out.

Those Transfer case bolts were tight! Had to put a cheater bar on the Allen key.

Made a hell of a mess on the drive way. Normally I'm really good with the catch pan, but I guess I misjudged it, and about a quart of motor oil made it onto the driveway.

Then took it out for a run around the block, and pissed one of the neighbors off because I went full throttle to speed limit.

Grabbed the Tech2 and cleared all the modules from me turning on the ignition while I had the PCM/TCM out.

New problem, if I am going thru a long corner at speed and apply brakes, it pulls right. If I am going straight, and apply brakes, it goes straight.
 

Mooseman

Master Blaster
Moderator
Dec 4, 2011
22,325
Ottawa, ON
New problem, if I am going thru a long corner at speed and apply brakes, it pulls right. If I am going straight, and apply brakes, it goes straight.
I also have some pulling to the left while braking with the TB right now. Was worse when I had the worn inner tie rods. Brakes are in good condition and sliders are good. I'm thinking a caliper is getting stiff. My next likely attempt will be to swap the calipers. I have the ones I kept from the Saab when I scrapped it since they were fairly new. Maybe to check whether it's the front or rear brakes, I may pinch off the rear lines and test drive it. Might also pinch one of the front at a time to see the effect.
 

Forum Statistics

Threads
22,038
Posts
620,760
Members
16,485
Latest member
SilentViper

Members Online

Members Online

Members Online