LH mirror heat ?

#1
It looks like I have no heat to my LH mirror RH mirror works as well as the rear window heat I could not see if there was a fuse for LH mirror in my manual. It seems like everything else is fused. Has anyone else come across this problem. I am thinking it must be electrical to that side. I have a 05 Envoy 4.2L
 

smt 59

Well-Known Member
#2
You will need to replace the mirror insert, the element burns out. Easy and quick fix as it pulls off the centre mount and new one clips back on with two wires that you pull off and replace back on the new insert. Tip for the wire connector, use dialectical grease.
 
#3
That or a wire corroded off the connector. And pulling the connector off the back of the mirror to fix it will usually break the element in the mirror. You can try to solder the wire back onto the connector still on the mirror.

IIRC, they are both powered by the same fuse as the rear defogger.
 
OP
OP
T
#4
You will need to replace the mirror insert, the element burns out. Easy and quick fix as it pulls off the centre mount and new one clips back on with two wires that you pull off and replace back on the new insert. Tip for the wire connector, use dialectical grease.
Thanks for the info guys.as far as pulling the mirror off do u just angle the mirror so I can get behind it with something and pull out also is the connection plastic so does it have to be done at a warm temp
 

smt 59

Well-Known Member
#5
Yes just angle down and get a screw driver behind and ease it off, how cold is it were you are? If you can get into a warm garage it would be better. Yes it is plastic.

Ahhh your from Ontario as well!
 

Members online

Forum statistics

Threads
18,653
Messages
567,550
Members
11,275
Latest member
Terrymemmos

Members online

Top Bottom