Just joined after enjoying your site

Expeditor

Member
Just joined your great site. I have been reading for the past three weeks decided to take the plunge. I have a 03 Envoy with a bad engine, bought it real cheap to fix myself. Hope to learn and share my experience with the rest of the members. Thanks for the opportunity to join your group.
 
OP
OP
E

Expeditor

Member
Welcome! I have experience in swapping an engine in these. It's fun! :crazy:
Ahhhhh the legendary Mooseman, Thanks to you I have gathered many publications that will surely come in handy. Thanks so much. Yeah the engine is out now. Deciding whether to buy re manufacture or rebuild myself. I believe the crank is toast. Spun number 6 rod bearing.
 

Mooseman

Moderator
There is a thread somewhere regarding getting an engine at a pick-n-pull or a regular used one but for a Turbo build. Not sure if anyone actually completed a rebuild here.
 

Redbeard

Well-Known Member
My comment is just a running joke to new folks. Often folks will mention they have a problem, but without any codes or useful info or history. So we often say first get throttle body cleaned out and what codes are showing. Good to hear something "simple" caused the codes and easily rectified on your engine.
 
OP
OP
E

Expeditor

Member
My comment is just a running joke to new folks. Often folks will mention they have a problem, but without any codes or useful info or history. So we often say first get throttle body cleaned out and what codes are showing. Good to hear something "simple" caused the codes and easily rectified on your engine.
Ha Ha, that is funny, I do have a problem with no codes, Its called a spun rod bearing. Will have to look for a new or used crank.
 

Mooseman

Moderator
OP
OP
E

Expeditor

Member
Did you clean the throttle body and disconnect the battery? :biggrin:
Sure did, removed the TB and then the battery. Cleaned the TB and before installing made sure battery was connected and ignition on. :smile:. Just like HVAC actuators, wanted to make sure TB was calibrated. lol

Just kidding folks, please don't do it the above way.
 

TollKeeper

Well-Known Member
I think the guys, in their great effort of teasing, forgot about the extra red wire at the battery....
 

Online statistics

Members online
6
Guests online
176
Total visitors
182

Members online

Forum statistics

Threads
19,309
Messages
578,136
Answered questions
1
Members
12,031
Latest member
T5Ent
Top Bottom