Driver door wiring issue ithink

Driver door module isnt working and im trying to find out why ive checked the boot in the door jam the one coming from the suv main wire harness has power and is grounded properly. But i lose power up at my connectors at the door module and nothing works. But if i try all of the other switches those all work even with the driver door unplugged.. please help anything would be better than nothing.


2005 gmc envoy
 
Last edited by a moderator:

xavierny25

Well-Known Member
Chances are the ddm is fried. Try swapping over the pdm to the drivers side and report back.
 

xavierny25

Well-Known Member
Seems your going to have to remove the door panel and inspect the wiring further.
 
Before you go too far check the ground to the body. This is a common failure point. It is behind the kick panel driver side (obviously lol) remove it, clean to bare metal, and reinstall. You may have to cycle the key a couple of times before it reads the bcm.
 
OP
OP
R
I'd be looking for continuity between what's in the door and on the other side of the door boot.
I checked the door boot and i have power

Before you go too far check the ground to the body. This is a common failure point. It is behind the kick panel driver side (obviously lol) remove it, clean to bare metal, and reinstall. You may have to cycle the key a couple of times before it reads the bcm.
Gonna give this a try next i yhink
 

Blackstar

Well-Known Member
I had a problem with mine a couple years ago. None of the buttons on the driver's side door worked. Swapped out panels with the passenger side. Driver's side worked on the passenger side but not the other way around. I tried new switch panels with no success. Tech told me he could check my wires but he would be paid by the hour to search for a problem. He showed me where to look. After tracing the wires from the switch to everywhere it went I removed the driver's side rocker panel cover and there it was. One wire (forget the colour) was cracked, corroded and stuck to the rocker panel. Cleaned it up, repaired the wire and it has been working fine ever since. Good luck.
 

budwich

Well-Known Member
Yea i just can't figure out what all wires should be hot lol.
??? what do you mean.... the diagram that you posted seems pretty well laid out.... both oranges appear to provide power to the door module. What do you get there?

the reason the other controls work is that if you look at the diagram, they get their power on their own feed. As suggested, you need to check those feeds going to the DDM.
 
Last edited:

Forum statistics

Threads
18,759
Messages
569,483
Members
11,396
Latest member
shane42037660

Latest posts

Top Bottom