NEED HELP Default Airbags will not inflate on automatically, but will manually.

Gearheadvr4

Well-Known Member
I replaced the bags with the ARNOT brand bags thinking that was the issue... but now I realize the compressor will not kick on automatically or when I'm driving around. I can inflate the bags manually and it will stay inflated at least overnight before they leak out. (So I know I do have a leak but I can tackle that later)

Could both leveling sensors be bad? What else could cause this? The SS did sit for a long time with the battery removed, not sure if that matters. If it is the leveling sensors does anyone have a part number?

 

07TrailyLS

Well-Known Member
Coil spring conversion ftw
 

therealsethallen

Well-Known Member
My guess is you knocked the ride sensors out of whack when you put the bags in the truck. First suggestion is to pull the fuse in the underhood fuse block. It's abbreviated ECAS in the little diagram on the cover and I believe it's fuse #1 but the 6.0 may be different.

There's a guide to lowering the truck with the factory bags on TBSSOwners, it may be worth a read to see if that might be a possibility for you.


TBSS Owners Factory-Air Bag Lowering Guide
 
OP
OP
Gearheadvr4

Gearheadvr4

Well-Known Member
It was the arms of the sensors, I just replaced the arms and all is good to go. I used that link to set up the rear to nice l
 

Online statistics

Members online
8
Guests online
144
Total visitors
152

Forum statistics

Threads
19,527
Messages
581,412
Unanswered questions
1
Answered questions
1
Members
12,260
Latest member
Quadzilla
Top Bottom