blower motor

larryizacat

Original poster
Member
Jul 3, 2012
5
i recently had to replace the underhood fusebox on my 04 trailblazer with one from an 05. everything else works except the blower for the heat and a/c. the set up where it plugs in is the only difference in the boxes. any ideas if i need to modify anything or other possible suggestions?
 

The_Roadie

Lifetime VIP Donor
Member
Nov 19, 2011
9,957
Portland, OR
Can you post pics of the area? Do you have the manual or the digital/Automatic blower control? Did the fuse block come from the same kind of vehicle?

What was the nature of the damage that made you change fuse blocks?

Do you have a meter and want to dig into the circuits?
 

larryizacat

Original poster
Member
Jul 3, 2012
5
it's the digital control, and unfortunately i don't have the old fuse block to show a comparison. can only describe the difference as being that the plug for the blower is extended out from the block slightly on the 05 whereas the 04 was in a row of 3. i rearranged the fuse in accordance with the 05 schematics, but nothing. What initially caused the replacement was my headlamp relay, which was an aftermarket replacement, fried and burned through the box. everything was rewired and works fine now, but just unsure if i should just try to locate an 04 block or dig deeper, because the area of the blower plug in was completely unaffected seemingly
 

larryizacat

Original poster
Member
Jul 3, 2012
5
i have not. can't seem to locate one for the 05. just don't know what model it came from and if there is any variance in how it hooks up in regards to mine which is an LS. If you know where to look for that initally it'd be appreciated
 

Forum Statistics

Threads
23,483
Posts
639,847
Members
18,716
Latest member
sloftin

Members Online