2005 Trailblazer crank no start

Dheinen

Newbie
Original poster
Jul 11, 2021
8
Northwood,IA
05 Trailblazer Won’t come out of park? Also cranks and no start? Related? No codes. Acts like it’s going to run and then dies right away. Like 2 seconds. Excellent compression…. Guy I bought it from thought it had transmission issues but once I drove it home it felt like drive ability issues. Replaced spark plugs and a bad coil. Also replaced throttle body for a code. Now it won’t run except for a second or two. Did a relearn on throttle body?
 

TJBaker57

Guru
Aug 16, 2015
2,000
Colorado
05 Trailblazer Won’t come out of park? Also cranks and no start? Related? No codes. Acts like it’s going to run and then dies right away. Like 2 seconds. Excellent compression…. Guy I bought it from thought it had transmission issues but once I drove it home it felt like drive ability issues. Replaced spark plugs and a bad coil. Also replaced throttle body for a code. Now it won’t run except for a second or two. Did a relearn on throttle body?


With key at RUN, listen for a click when the brake pedal is pushed. A second click should be heard when the button on the shifter is pushed in. There are some interlock switch systems to prevent unintended shifting and such things.

If it starts normally but dies after two seconds,,, does the security light turn on when it dies?? There is a security feature of sorts that disables the fuel a couple seconds after startup if there is not certain communications between PCM and BCM. Exactly when did the no start begin? Before the throttle body work, after the throttle body work? Before the plugs and coil or after?
 

Mooseman

Master Blaster
Moderator
Dec 4, 2011
21,859
Ottawa, ON
Check your ignition switch for proper output. Replace if necessary. It's a common failure part with electrical gremlins.
 

Dheinen

Newbie
Original poster
Jul 11, 2021
8
Northwood,IA
Not hearing the clicks when brake is pushed or the button is pushed in. This thing ran like crap when I drove it back to my place. Did the tune-up. Misfire code on #1 went way. Had a code for throttle actuator PO 2176 so put the throttle body on it. Never ran since and I’m thinking I did the relearn correctly.
 

Mooseman

Master Blaster
Moderator
Dec 4, 2011
21,859
Ottawa, ON
Is the throttle body you put on it clean? You have to disconnect the battery for at least 30 minutes. This will also reset the fuel trims. Should still check ignition switch output for the shifter lock.
 

Mooseman

Master Blaster
Moderator
Dec 4, 2011
21,859
Ottawa, ON
Have seen some that failed that when turned to crank, some power gets cut off.
 

JerryIrons

Active Member
Dec 20, 2011
420
It's getting fuel right? After sitting overnight, if you put the key to run but not start, you should hear the fuel pump run and pressurize the system. You've got good battery connections and grounds? I would be tempted to replace the ignition switch, when those things go bad weird things happen.
 

KEEBZ489

Registered Member
Jan 16, 2018
219
Howard Beach NY
MAIN FUSE ? i had similar issues when my coil died , it blew the main fuse , crank but no start. new main fuse and there was a misfire , 6 new cils and plugs and was good as new
 

MRRSM

Lifetime VIP Donor
Oct 22, 2015
5,729
Tampa Bay Area
Just in Case... If you recently purchased the SUV and it had been sitting for any length of time, be advised that we have had instances during "The Long Year of COVID-19" involving SUVs that were left parked and unattended for extended time frames; long enough for Rodents (like the Dreaded Hanta Virus carrying Deer Mouse) to move in and 'set up house keeping'.

These Vermin succeeded in some case at gnawing through not only various Wire Harnesses... but also destructively chewed through Electrical Connectors. Take a Bright Flashlight and give the Engine Nacelle a REALLY good going over. Look for any additional signs of Ruined insulation, Pine Needles and Animal Fur being collected as Nest Building Materials. If you find ANY such artifacts 'in situ'...Mask and Glove Up First to avoid Breathing in or Touching the Desiccated Hanta Virus Infected Urine and Feces from these disgusting animals. Here are some images of a Rodent Damaged GMT360 Vehicle:
 

Attachments

  • IMG_20200208_135901440.jpeg
    IMG_20200208_135901440.jpeg
    53.7 KB · Views: 5
  • IMG_20200208_140623372_HDR.jpeg
    IMG_20200208_140623372_HDR.jpeg
    81.8 KB · Views: 4
  • IMG_20200208_140636317_HDR.jpeg
    IMG_20200208_140636317_HDR.jpeg
    53.2 KB · Views: 4
  • IMG_20200208_140734498_HDR.jpeg
    IMG_20200208_140734498_HDR.jpeg
    28.5 KB · Views: 4
Last edited:

coolride

Hobbyist
Aug 23, 2019
574
Adirondacks
Why did you replace the original throttle body? If I understand right (34% chance,) you installed a new one and then developed a no start situation.

Maybe re-install the old throttle body and see if the engine starts.
 

Dheinen

Newbie
Original poster
Jul 11, 2021
8
Northwood,IA
Shifter has corrected itself and don’t know what I did. Going to clean all grounds and starter connection tonight and bring a scanner home from work. Any readings I can look at for fuel injectors?
 

MRRSM

Lifetime VIP Donor
Oct 22, 2015
5,729
Tampa Bay Area
You might want to check on the Park Neutral Safety Switch Alignment as it can be a bit touchy when reconciling the position of the Shifter Handle with the ACTUAL position of the PNS in its adjustable positions. A worn out Nylon Button in the end of the Shifter Cable Lever Attachment Fixture can also affect this issue.:
 

Attachments

  • PARKNEUTRALSAFETYSWITCH.jpg
    PARKNEUTRALSAFETYSWITCH.jpg
    39.9 KB · Views: 6
  • ADJUSTHEPARKNEUTRALSWITCH1.jpeg
    ADJUSTHEPARKNEUTRALSWITCH1.jpeg
    80.9 KB · Views: 6

Forum Statistics

Threads
21,841
Posts
618,161
Members
16,090
Latest member
Tech ACG

Staff online

Members Online

Staff online

Members Online

Staff online

Members Online