06 trailblazer cranking issue

Liketalknbout

Newbie
Original poster
May 2, 2022
7
Port Allen , La
My trailblazer will spin over then disengage then try to re engage and grind on the flywheel has any one had this issue. When it does start it runs fine. It just won’t turn over enough to start , any suggestions on this issue . New battery , cables are good no corrosion on connections. Reyes to start in neutral does the same thing turns over like one time then starter disengages then try’s to re engage and grinds
 

TollKeeper

Platinum Donor
Dec 3, 2011
6,711
Brighton, CO
How long is it cranking, timed, before it finally starts?

Any MIL/Check Engine lights on?
 

Liketalknbout

Newbie
Original poster
May 2, 2022
7
Port Allen , La
Had a cel on before it started acting crazy I don’t remember what It was , trying to put code scanner on it now I did change the battery so it may have cleared the light. It would spin over about 3 to 4 full turns before starting when it works . At one point i could jump it off and it would start fine is why I changed the battery but now it just does it’s spin one time and starter disengages now
 

Liketalknbout

Newbie
Original poster
May 2, 2022
7
Port Allen , La
It is showing a po449 code right now evap emission control system vent valve solenoid circuit, replaced valve did not clear code replaced connector did not clear code
 

Liketalknbout

Newbie
Original poster
May 2, 2022
7
Port Allen , La
Had a cel on before it started acting crazy I don’t remember what It was , trying to put code scanner on it now I did change the battery so it may have cleared the light. It would spin over about 3 to 4 full turns before starting when it works . At one point i could jump it off and it would start fine is why I changed the battery but now it just does it’s spin one time and starter disengages now
How long is it cranking, timed, before it finally starts?

Any MIL/Check Engine lights on?
Turns over like 3to4 full rotations to start usually , it was running fine then started doing this crazy crank and stop thing but would still start after a few try’s now only half a rotation maybe a full rotation and starter kicks out then it grinds
 

TollKeeper

Platinum Donor
Dec 3, 2011
6,711
Brighton, CO
That could be a couple things. From the ignition switch, to a relay, to a starter.

But basically, what you are saying.. Even if you have the key manually turned to start, the starter will disengage?

I dont think the MIL code is related..
 

Liketalknbout

Newbie
Original poster
May 2, 2022
7
Port Allen , La
Yes it kicks out just after turning the key I get about a half a rotation from the engine that’s it . I was leaning towards the switch but it always try’s to start when turning the key all the dash lights work all the gages are working the alt gage is acting wired but that’s the only change in anything . Not draining battery
 

TollKeeper

Platinum Donor
Dec 3, 2011
6,711
Brighton, CO
I would likely start by swapping the starter relay with another one in the fuse box. Most of them are the same relay. I know someone on here has a bit more experience with the ignition switch to say if its related or not.
 

Mooseman

Master Blaster
Moderator
Dec 4, 2011
22,325
Ottawa, ON
What does it do if you jump the starter relay? Will it keep cranking as long as you jump it? Pull the relay and check the ground signal the PCM is sending to it. Is it steady for 5-10 seconds? Check the fuse for it to see if the contacts in the fuse box and clean and tight.

I would try to diagnose this as a no crank issue.

 

Forum Statistics

Threads
22,038
Posts
620,760
Members
16,485
Latest member
SilentViper

Members Online

Members Online

Members Online