'04 Trailblazer surging when cruise is set going down hill

hotrod1984s10

Original poster
Member
Apr 5, 2012
9
Hello Gent's,
I'm new to the site and new to my 2004 Trailblazer LS 4x4 I6. On a long trip yesterday while the cruise is on, when going downhill the truck feels like it's surging very slightly. This only occurs on downhill grades. Is this a common issue? The cruise works perfectly otherwise. This is my first 4x4 vehicle (although I'm operating it in 2wd). Thanks for any comments.:thumbsup:
Robert
 

hotrod1984s10

Original poster
Member
Apr 5, 2012
9
Thanks, Yup the throttle body was recently cleaned by the dealer by the previous owner. The engine runs very smoothly, no issues. I stated surging as thats the only word that I can think of describing the issue. It's almost like the truck is trying to slow down on a grade, but the surging only occurs going downhill, and it kind of like pulses while coasting? Otherwise it runs extremely well.
 

The_Roadie

Lifetime VIP Donor
Member
Nov 19, 2011
9,957
Portland, OR
hotrod1984s10 said:
Is this a common issue? The cruise works perfectly otherwise.
Welcome! It's a totally well-known problem, caused by the cruise control software in the PCM. I have the issue as well. If I remember correctly, GM might have an attempt at a fix in later PCM updates, but dealers don't give those away for free. You can ignore it or turn off the CC for those downhill sections.

Ummmm, nothing to do with the throttle body stickiness, which is only apparent at idle when the AC compressor cycles on and off. Not that it's a bad preventive measure anyway every 30K or so miles.....:thumbsup:
 

hotrod1984s10

Original poster
Member
Apr 5, 2012
9
Thanks very much for the information. It's refreshing to know that any and all questions can be answered on this forum. Mr Roadie, your the man!!:wootwoot:
 

Forum Statistics

Threads
22,619
Posts
629,338
Members
17,347
Latest member
19nanook72

Members Online