Search results

  1. Mike534x

    Stuck on rear camera install

    Hello everyone! I'm finally installing a back up camera into the Envoy, but I've hit a bit of a snag. Currently, the camera is mounted/installed within the license plate holder between the two lamps. I have the video wiring somewhat routed, not perfectly but will back at another time to make...
  2. Mike534x

    Removing pin strip/accent running across body panels

    Hey everyone! Does anyone have advice on how to remove aftermarket pin stripping/accents? I assume this was done aftermarket by the dealer, but there is this lone silver strip that starts at the front fender and goes across the door panels and ends at the rear (it covers both sides of the...
  3. Mike534x

    Weird voltage fluctuations

    Hi all! I'm trying to track down a gremlin in the Envoy. Past few months since summer decided to show itself I've been experiencing intermittent voltage drops, usually drops to the 11.5-12 range give or take. Usually only happens for a second or too regardless if I'm at idle or driving. This...
  4. Mike534x

    Rear end squeak/creek

    I've been chasing this problem down for months, and nobody seems to be able to know what the issue is. Basically, when going over bumps there will be a light squeak/creek coming from the rear end somewhere. The sound is way more prominent when there are passengers in the rear, as in, every...
  5. Mike534x

    Did I just kill my BCM?

    Just as the title says. I replaced the battery on my truck, however, I bought one of those memory saver adapters that plug into the cigarette lighter. In my hast to get to the store before they closed, I plugged it into the 12V outlet thinking it was the standard one (yeah......). I hooked...
  6. Mike534x

    Lazy Lifter?

    Well this is a new one, so yesterday was the first time I have heard anything abnormal coming from the engine bay and I'm trying to see if anyone has any guesses as to what it could be. I was out and about, upon starting up the Envoy (after it was already warmed up) I was greeted with this...
  7. Mike534x

    Exhaust Recommendations?

    So I'm getting the mod itch again, and I've done some searching on here and it seems to be a toss up between Magnaflow and Flowmaster. I plan on keeping the factory setup and resonator, just swapping out the muffler. Seems a little counter intuitive, but I'm looking for noise, while keeping it...
  8. Mike534x

    Disconnected battery, blowing cold air when heat is on

    I've got another problem, it feels like I've entered a domino effect with the repairs being done to the Envoy so far. My latest issue is that my heat isn't working properly, and it was fine up until I had the battery disconnected. Long story short, PCM was sent out for a tune and had DoD...
  9. Mike534x

    Bad gas cap or Purge Solenoid?

    Hi everyone back with another problem this time. Got a message on my DIC about 3 weeks ago saying I need to tighten my gas cap, after doing some searching and calling a few dealerships they said it was the gas cap. We'll I bought a new AC Delco gas cap from rockauto and changed out the old one...
  10. Mike534x

    FOR SALE Trailblazer Part Out (various years)

    Hopefully I'm doing this right, I came across this CL ad while hunting down a new rear hatch glass. Looks like the parts are from various trim and model year Trailblazers, not my ad but I wanted to pass this along here to see if it benefits anyone! :biggrin...
  11. Mike534x

    ABS Code C0040?

    Alright, I've been trying to solve this problem for the past week and a half and need some help. The Envoy suffers from the infamous "ABS shutter" when doing 5 MPH or less coming to a stop, hooking up the code reader revealed that it was the front right side speed sensor. I went in and took...
  12. Mike534x

    Replacing Power Steering Lines?

    Hey everyone, looking to see if anyone has first hand experience with replacing the power steering lines on a 360 with the V8. My new to me Envoy Denali has a very small leak where it meets the steering pump (I can post a picture of it tonight if needed), the previous owner had purchased a...
  13. Mike534x

    Sound only coming from Front Tweeters and Rear speakers

    So this has been bugging me for awhile now, and I finally want to address it with the free time I have. When I purchased the TB it came with the factory Bose HU, at the time it appeared that all the speakers were working correctly. About a week into owning it, we had the Pioneer AVH-X3600BHS...
  14. Mike534x

    Lifters replaced, other issues popping up

    Hello everyone, seems like its becoming constant that I'm posting about something with my TB haha. I made a post in Mooseman's thread that lists the sensors that deactivate the DoD, and its been about a week so far and I've noticed a few things. Here's what happened which will lead up to my...
  15. Mike534x

    Outside rear panel cracked/split?

    Went outside to grab something from the garage and noticed this near the passenger side rear door. I know it definitely wasn't there a few days ago, and have absolutely no idea how it even happened. I assume this isn't a DIY type of fix is it?
  16. Mike534x

    How to replace Rear Heating & A/C assembly?

    Does anyone know what's needed to replace the whole rear heating and A/C assembly hidden behind the passenger side panel on the Ext. Trailblazer? When we bought the truck it wasn't working, so I loosened the 4 screws to pop off the panel to inspect the actuators and I noticed the power connector...
  17. Mike534x

    Bad thermostat?

    Hi everyone, trying to figure out if my thermostat just went bad or the coolant temp sensor is bad. We bought the TrailBlazer last year. It's sitting at 157K miles and we have no idea what the maintenance history is on this thing was. To start it off (just a run down of what we did so far)...
  18. Mike534x

    No Power Steering, Bad pump?

    Hi everyone, Got up this morning and noticed the truck has no power steering at all. Checked the fluids which were full, no abnormal noise coming from the engine bay, steering comes back when the engine is revved up and goes away when it settles back at idle. Is the pump bad or is this an issue...
  19. Mike534x

    Adding 3rd row seating to an Envoy XUV, is it even possible?

    Just wondering if something like this has been done or if its even possible. My neighbor has an 04 XUV and wants to add 3rd row seating for whenever his daughter/her family come to visit and he doesn't really use the cargo bed so instead of trading it in for one that does, he wants to know if he...
  20. Mike534x

    Hard start and rough shut down

    It's been about a year now since I last posted when we still had our 02 Envoy. Recently my parents bought an 04 Trailblazer Ext for my brother to drive to school and its having some minor issue we can't seem to figure out. Currently its sitting at 143k miles and has the I6. Here's what we've...
  21. Mike534x

    Rough Idle + P0430 and other issues

    Hi guys, need some help with my dad's Tahoe. First off its an 07 Tahoe LTZ with 99,309 miles and recently the CEL came on and it reads as a generic P0430 and the idle seems a bit rough, after reading up on it it seems to be related to the catalytic converter, one of the 02 sensors or an exhaust...
  22. Mike534x

    Better late then ever?

    Hi Everyone, I usually lurk more than I post and thought it would be important to introduce myself properly instead of making a post asking for help and then become "that" guy that just comes around asking questions and doesn't contribute back haha :smile: Before I heard of GMTNation, I used to...
  23. Mike534x

    Bad TCCM or something else?

    Hi guys. Having problems with our Envoy recently - again - (2002 SLT) 3 weeks ago we replaced the alternator (had it tested but there was no change in the amperage as engine rpm increased or when load was placed on it. Few days later it sounded like a baring went out and there was a strong...
  24. Mike534x

    Engine ticking, possible to quiet it down?

    Hi everyone! Our Envoy has this Engine tick that still exists even after the engine is warmed up from a cold start. My parents bought our 02 Envoy with 42,000 miles back in 04 and now its creeping up on 142K, and it has always had this engine tick which sounds exactly the same as gmcman's...

Members online

Forum statistics

Threads
18,543
Messages
565,764
Members
11,131
Latest member
Hammer41514
Top Bottom