Search results

  1. I

    Installed new Android Stereo thoughts.

    The original pictures above are before I got the Aftermarket dash kit and was just basically sitting in the opening. I since bought this and had to shave a decent amount using a dremel. The good thing is that the factory trim for the dash actually covers over the corners and very edge of the...
  2. I

    Weird Electrical Issues (Radio on all the time, Door courtesy light not coming on, etc.)

    I'm not sure exactly what the problem was, but since the issue first showed up it hasn't happened since, although I've changed a couple of things since it happened, DIC, Battery, Instrument Cluster, Steering wheel. Not sure which one of those it was but I figure it's Either the DIC harness or...
  3. I

    2008 Trailblazer LS Build

    Had the header installed finally, still had a bit of an issue with spark plug wire clearance on Cylinder 2. I figured I could get away with running the Stock wires for a few weeks but almost immediately began to get a Misfire Cylinder 2 Code. Added new PCMofNC Wires and Socks and all looks well...
  4. I

    Dashcam Videos

    I bought a Thinkware F750 About a year ago after I sold my Jeep and got a new Charger. Not sure what it was, but people started cutting me off, pulling out in front of me, running red lights etc. Mostly all Downtown Dallas. Never had that problem in the Jeep GC ¯\_(ツ)_/¯ Saved me when I was...
  5. I

    2008 Trailblazer LS Build

    Rant ahead... Well i'd have liked to have been done with this already and moved on to the suspension or fixed the Clockspring but nope. Looks like I should have trusted the reviews that Pacesetter is crap. I reached out to Pacesetter Friday October 7th, Showed them the pictures I posted here...
  6. I

    2008 Trailblazer LS Build

    Added a few more things... New Construction options Well this whole last week has sucked. Been trying to get the headers installed but either I got a pair that were messed up by the factory or the 5.3L's aren't actually supported. Basically the headers are too close to the driveshaft...
  7. I

    2008 Trailblazer LS Build

    So I thought i'd take these 6 back to back videos of the 0-60 pre tune and post tune but it turned out that the cam recording app I used has like a 1-1.5s delay on startup and one of the pre tune videos disappeared. Overall it appears to have lowered my 0-60 by 1.5-2s. This is in conjunction...
  8. I

    2008 Trailblazer LS Build

    Yeah I read the Thread from The Roadie on the old site but I'm no good at soldering. So unless I can find a cheap place to test it here I'll end up buying another one I think...
  9. I

    2008 Trailblazer LS Build

    Appears that way. I'll see if I can track down another at a salvage yard. Really don't want to pay for a new one...
  10. I

    2008 Trailblazer LS Build

    A few updates, 160 T-stat installed, gatorback Belts Installed & new Headlights installed (Highs unable to be installed since the cheap Chinese housing didn't leave enough room to insert the connector+lamp into the drivers side. So I left the Cheap high lamps in it instead of the Silverstars.)...
  11. I

    2008 Trailblazer LS Build

    I figured rather than just using/making new/existing threads for pictures i'd throw it all in One thread. Just bought my 2008 Trailblazer after Wrecking my 2004 Trailblazer in 2012. So far here's what's been done. I bought the car to be a Daily Driver and replace having to drive my 2015 Charger...
  12. I

    Efan question

    Efans installed and PCM patched tonight. I won't know anything for sure on Temps for a while, last week it hit 92 here in Fort Wayne....maybe it will get close again? As of tonight when replaying the HP Tuners log it didn't go above 202° and I was trying to stress it. Mac A/CEI and plenty of...
  13. I

    08 5.3L SWB Considering LS3 Swap, Questions

    You're awesome sir, found it withing 10 minutes of searching, sorry about that :(
  14. I

    08 5.3L SWB Considering LS3 Swap, Questions

    Just following up with you guys on the last part for adding a few factory options, working on transplanting in some SS seats and Tach next week, I came into a clockspring and steering wheel Controls for cheap so I wanted to know if anyone had an updated writeup on the DIC Upgrade? I looked here...
  15. I

    Weird Electrical Issues (Radio on all the time, Door courtesy light not coming on, etc.)

    Gotcha I'll order one for the weekend then. When you say Ignition switch do you mean Like this or like this?
  16. I

    Efan question

    Just called and ordered the parts from PCMofNC, they said yes, 98-02 Camaro & Firebird are the same Fan V6 or V8. So that should save some folks a bit of money, since LS1 anything seems to add to double the cost of the part.
  17. I

    Weird Electrical Issues (Radio on all the time, Door courtesy light not coming on, etc.)

    Hey Everyone, Figured I'd make this a separate thread from my Efan question, and quickly before the Ambien kicks in! (Edit: Already has, posted this in the Tahoe Forum accidentally) :tongue: Since I've bought the truck i've started having a few strange issues, the biggest happened tonight as I...
  18. I

    Efan question

    They look the same but they are different part numbers.
  19. I

    Efan question

    Hey everyone, Am buying a performance kit from PCMofNC and it has the Efan conversion kit. I decided to try and source one locally. 73 Miles away is a 2000 LS1 Camaro Fan assembly for $65, or locally about 5 Miles away there is a 1999 3.8L Firebird Dual Fan Assembly for $30. $35 with a...
  20. I

    Installed new Android Stereo thoughts.

    Just got done Rooting the Nav unit and changed a few things, boot logo & animation is now the Chevy symbol, Changed the dock, and Also changed the audio driver with a different app that makes a huge difference in audio clarity! Like going from Flat stock radio sound to a perfect sound stage...
  21. I

    Installed new Android Stereo thoughts.

    If you don't mind me asking what issues are you having and when did they appear? I ask because some people on Amazon have said they start to see issues in the Unit about 2-4 weeks in (GPS not working, or Wifi Not working) I'm assuming GPS would be either a bad GPS Mount or the Cheap GPS...
  22. I

    Installed new Android Stereo thoughts.

    Hey Everyone, just got done this weekend installing one of those Chinese brand Android Radios. For a equivalent Nav/DVD unit from Alpine or Kenwood it was about $750+ while I got this with wiring harness, and dash kit for about $250 with overnight shipping from Amazon. You can find them under...
  23. I

    08 5.3L SWB Considering LS3 Swap, Questions

    Thanks everyone, great info. I'm in touch with a guy in Cleveland and am looking to do the swap about 6 weeks from now depending on delivery and whether or not it's snowing yet. If it is it'll probably be later since I don't really wanna drive the Charger in the snow. So i'm looking at the...
  24. I

    08 5.3L SWB Considering LS3 Swap, Questions

    Gotcha, well that's good news, it seems fairly hook up and go as far as physically swapping, just wondering about Harness/ECU. It is 4WD, what kinda complications am I looking at for that? I read that the LS1 on the SS highly recommended the pickup relocation due to it being up front and...
  25. I

    08 5.3L SWB Considering LS3 Swap, Questions

    Hey Everyone, Been a few years since I've been by. I just bought a 2008 SWB 5.3L. Coming from a Jeep Grand Cherokee with a 5.7 Hemi and My Charger with the 6.4L I wanted something a bit faster (Yeah should have probably just saved and got an SS, but I wanted a project) I was considering two...
  26. I

    Something leaking in passenger floorboard?

    Thanks everyone, it worked perfectly! and about a gallon of water came out...tons of black sludge and a few Pine Needles (Dafuq?) were inside their.
  27. I

    Something leaking in passenger floorboard?

    Lol ^.^ thanks for the help guys, I'm at work currently but once I finish my site I'll probably see about getting that hose fixed :biggrin:
  28. I

    Something leaking in passenger floorboard?

    hey everyone, been a while since I was on, i'm trying to figure out whats going on here....i'm sure its an A/C issue as this started....about a month ago....but it's random...usually when the A/C is turned to 60 but sometimes if its 70-75 on a higher output, anyway water will cover the passenger...
  29. I

    Horn Not working...

    whaaa? me? I would never...Maybe a bit... :wootwoot:
  30. I

    Horn Not working...

    so far so good, the horn seems to be working great :D thanks again!

Online statistics

Members online
8
Guests online
194
Total visitors
202

Members online

Forum statistics

Threads
20,531
Messages
596,682
Unanswered questions
2
Answered questions
2
Members
13,672
Latest member
Sonny Gill
Top Bottom