Search results

  1. H

    SOLVED! No crank, sometimes clicks and other times doesn't

    Hi, it's me again! :bonk: My '06 Envoy XL Denali 5.3L LH6 has stopped cranking out of the blue. It's been sitting in the scrapyard since late 2011, so I can't get shocked if the starter suddenly went bad. After all that, I do believe that the starter needs replacing. I'm not sure what...
  2. H

    NEED HELP 06 Envoy XL Denali Brakes

    Hello, I've purchase an 06 Envoy XL Denali 5.3L from scrapyard that seemed to be in good mechanical condition. Based on the tires and the spare it came with, I suspect that the car's been sitting since 2011 (tires are 2010 and spare is 2006). After fabricating a key, it started right up...
  3. H

    A/C not working

    Hello, The car is a 2006 GMC Envoy XL Denali that I bought from a scrapyard. There is refrigerant in the system. However, it seems like the HVAC control module is not giving the command to engage the compressor. I tried supplying 12v to the clutch and it engaged! So I just need to figure out...
  4. H

    SOLVED! Security light solid on

    Hello peeps, So I my trailblazer has got crank issues and engine needs rebuild/replacement. Been looking in scrapyards to get a whole car and take parts from it. However, I found a 2006 Envoy XL Denali that looks to be in mint condition. It has around 146000 km on the dash and everything looks...
  5. H

    Ignition switch connector/plug

    Hello, I've been trying to find a connector for the ignition switch but to no avail. Does anyone know the name or number of that connector, or maybe even have a link? I'm thinking to make a T harness for the ignition switch and use that to connect the alarm system that I want, instead of...
  6. H

    Remote start system + extra feautures

    Hello, Disclaimer: I'm still in the planning phase and will start the work in a couple of months after I get everything figured out. I've been kind of going back and forth about getting the Viper 5706V, or preferably the 5906V aftermarket security and remote start systems for the past couple...
  7. H

    NEED HELP Brake pedal noise/No full pedal

    Hello, I have this weird brake pedal noise, and brakes apply firmly about halfway through (after the sound is gone) and I can't seem to figure it out. This is a video of the problem: Now let me give you a little bit of the brakes history on this car: So far, I've tried: - Bleeding the...
  8. H

    NEED HELP A/C Blowing hot air most of the time!

    Hello! I've been having a issue with my blazer's A/C since I got it about 2 years ago. It simply doesn't cool most of the time, especially in summer. This summer I went ahead to start fixing the problem. What I've done to begin with: - Replaced compressor with brand new ACDelco - Replaced...

Online statistics

Members online
7
Guests online
260
Total visitors
267

Forum statistics

Threads
20,446
Messages
595,079
Unanswered questions
2
Answered questions
2
Members
13,547
Latest member
rchalmers3
Top Bottom